[Portaudio] Re : Missing DllRegisterServer in portaudio_x86.dll

Wong, Milton milton.wong at lmco.com
Tue Dec 22 14:03:05 EST 2015


Thank you! I got it to work following #2.

M

From: portaudio-bounces at lists.columbia.edu [mailto:portaudio-bounces at lists.columbia.edu] On Behalf Of Robert Bielik
Sent: Tuesday, December 22, 2015 10:25
To: portaudio at lists.columbia.edu
Subject: EXTERNAL: Re: [Portaudio] Re : Missing DllRegisterServer in portaudio_x86.dll

That said, you should make sure that one of the following is true:
1) The DLL is in the same folder as the example executables
2) The DLL is on the search PATH so it can be found.

Regards
/R
Den 2015-12-22 kl. 17:45, skrev robert.bielik:

The DLL is not a COM DLL. Thus there is no DllRegisterServer function.

Regards

/Rob

------ Ursprungligt meddelande------

Från: Wong, Milton

Datum: tis, 22 dec 2015 17:09

Till: portaudio at lists.columbia.edu<mailto:portaudio at lists.columbia.edu>;

Ämne:[Portaudio] Missing DllRegisterServer in portaudio_x86.dll


Hello,

I am having a problem with portaudio on DirectSound/Windows 7. I successfully built portaudio_x86.dll using the solution that comes with the distribution, without error messages. However, I cannot register the DLL. RegSvr32 produces the error message: "The module portaudio_x86.dll was loaded but the entry-point DllRegisterServer was not found". Subsequent attempts to run examples code fail with "The program can't start because portaudio_x86.dll is missing from your computer."

Any suggestions are greatly appreciated.

Thanks,
M





_______________________________________________

Portaudio mailing list

Portaudio at lists.columbia.edu<mailto:Portaudio at lists.columbia.edu>

https://lists.columbia.edu/mailman/listinfo/portaudio

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.columbia.edu/pipermail/portaudio/attachments/20151222/62950bb4/attachment.html>


More information about the Portaudio mailing list