[Portaudio] Cannot install PortAudio on El Capitan

ericzhang at gmail.com ericzhang at gmail.com
Tue Dec 29 11:57:52 EST 2015


You’ll need the old SDKs or you’ll need to edit the install script to look for a different SDK.

-- 

Sent with Airmail

On December 29, 2015 at 11:48:24 AM, Michael Buckley (mbbuckley at umass.edu) wrote:

Hey everyone, 
So I'm new to programming in general, and I'm trying to teach myself audio programming using C/C++ and "The Audio Programming Book." One of the chapters relies heavily on the user being able to use PortAudio. However, when I try to do a build for PortAudio on my computer, I get this error 

configure: error: Couldn't find 10.5, 10.6, 10.7, 10.8 or 10.9 SDK



I have Xcode installed, version 7.2 I believe, and I'm running OS X 10.11. I've done some searching, and it seems like there is no SDK that comes with my version of Xcode, or something to that affect. A lot of this stuff is new to me. I'm not really sure what an SDK is or does and I'm pretty much just following instructions from the PortAudio tutorial. But now I'm stuck. I've tried to find an older version of Xcode, to just literally take the SDK out of that and put it in my Xcode contents folder, or just find a standalone SDK for download. Neither of these options seem worth pursuing, given the searching I've done and my level of experience with this type of stuff.

What are my options at this point? Is there a simple way to get around this and just get the PortAudio Library working with my program? And if not, I'm open to advice.

_______________________________________________  
Portaudio mailing list  
Portaudio at lists.columbia.edu  
https://lists.columbia.edu/mailman/listinfo/portaudio
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.columbia.edu/pipermail/portaudio/attachments/20151229/90d9984d/attachment.html>


More information about the Portaudio mailing list