[Portaudio] Portaudio PulseAudio HostAPI

Ross Bencina rossb-lists at audiomulch.com
Thu Dec 15 07:08:15 EST 2016


On 15/12/2016 5:53 PM, Tuukka Pasanen wrote:
> One
> thing that I have been thinking should Pulseaudio be turned on first
> with run time variable like PORTAUDIO_PULSEAUDIO=1 because there seems
> to be common fear that new untested Pulseaudio messes things up because
> ALSA is mature and working most cases.

An obvious option is to disable it by default with configure, and 
require people to explicitly enable it when configuring.

I'm not sure whether we should do that, but it's an option.

I don't think a runtime flag is a good idea myself.


> But if there is something that I have missed which prevents merge or
> Pulseaudio is unneeded feature that can be said now because it has been
> in works more than 3 years (and ready to merge more than half year).

I think we should merge it. But I would love for there to be more 3rd 
party code review (even just people saying that they reviewed the code 
and it looks good).

The main reason that I have been silent on the issue is that I have been 
busy studying and taking exams with little time for PortAudio.

Maybe I missed it, but did you respond to my previous request:

 >>     One additional request, if you haven't done this already:could you
 >>     please run the examples/tests with some kind of memory checker
 >>     such as valgrind or llvm AddressSanitizer/LeakSanitizer. Just to
 >>     check that your first-order memory handling is OK.

Thanks,

Ross.




More information about the Portaudio mailing list